#exult@irc.freenode.net logs for 13 Aug 2014 (GMT)

Archive Today Yesterday Tomorrow
Exult homepage


[01:48:39] <-- Dominus has left IRC (Ping timeout: 246 seconds)
[01:50:41] --> Dominus has joined #exult
[01:50:41] --- ChanServ gives channel operator status to Dominus
[02:05:31] --- ParuNexus is now known as mp5nexus
[03:02:19] --- mp5nexus is now known as ParuNexus
[06:53:50] <-- Lightkey has left IRC (Ping timeout: 250 seconds)
[07:06:33] --> Lightkey has joined #exult
[10:00:05] <-- Dominus has left IRC (*.net *.split)
[10:07:45] --> Dominus has joined #exult
[10:23:55] <-- Dominus has left IRC (*.net *.split)
[10:30:44] --> Dominus has joined #exult
[11:43:47] --> TheCycoONE has joined #exult
[13:24:03] <-- Kirben has left IRC ()
[14:37:22] <-- TheCycoONE has left IRC (Ping timeout: 245 seconds)
[14:38:52] --> TheCycoONE has joined #exult
[18:37:27] --> RadoS has joined #exult
[18:41:28] <-- rADo has left IRC (*.net *.split)
[19:00:52] --- RadoS is now known as rAdO
[19:22:09] <-- Marzo has left IRC (Ping timeout: 272 seconds)
[20:16:08] --> Firebrand9 has joined #exult
[20:16:47] <Firebrand9> ok, I'm hoping someone here can help me
[20:17:40] <Firebrand9> basically, I'm attempting to get Exult to use a local .cfg file, but despite it being filled out fully with all the paths, it is still stating that it cannot find the static data
[20:18:24] <Firebrand9> I can post my .cfg file somewhere online and elaborate to whatever degree is necessary. I have read the FAQ also
[20:19:23] <Firebrand9> I'm a technical guy. I program games and software professionally, but somehow this is eluding me
[20:21:11] <Firebrand9> here's the config : http://pastebin.com/xpLSMEA1
[20:22:42] <Firebrand9> Exult is launched with a batch file with the sole command : exult.exe --nocrc -c "D:\Games\Ultima VII\Exult_1.x\exult.cfg"
[20:24:17] <Firebrand9> if I remove the quotes around the path above, I get the Warning that it can't find the static data
[20:25:20] <Firebrand9> with them, it doesn't launch at all, but the (remote) stderr.txt contains the following :
[20:26:06] <Firebrand9> http://pastebin.com/cX4YkBr8
[20:26:54] <Firebrand9> so, even is spite of having --nocrc, it's still having some issue with that
[20:29:35] --- Firebrand9 is now known as Firebrand
[20:29:55] --- Firebrand is now known as Firebrand9
[20:33:13] --> Marzo has joined #exult
[20:35:07] <Firebrand9> maybe marzo will have some idea
[20:56:47] <Marzo> ?
[21:11:41] <-- TheCycoONE has left IRC (Quit: And then there were n-1)
[21:26:01] <Firebrand9> marzo : http://log.usecode.org/exultlog.php
[21:27:34] <Marzo> The flx files are built together with Exult, and their CRC is included in the source code
[21:27:50] <Marzo> (by the build system, I mean)
[21:28:13] <Marzo> If you are trying to open Exult with flx files of a different version of Exult, it will fail
[21:28:55] <Firebrand9> well, interestingly enough I *did* update those files with the ones currently out on the site
[21:28:56] <Marzo> Passing --nocrc makes Exult ignore the failed crc, but if something is missing in the file, or different than what Exult expects, it may crash
[21:29:15] <Firebrand9> here's the weird part
[21:29:18] <Marzo> That was the whole of stderr?
[21:29:24] <Firebrand9> yes
[21:29:30] <Marzo> What about stdout?
[21:29:54] <Firebrand9> one moment, I'll u/l it
[21:30:25] <Firebrand9> if I just forgo the whole local/specified .cfg file, it *will* work
[21:30:42] <Marzo> With the same paths?
[21:30:48] <Firebrand9> yup
[21:30:59] <Firebrand9> that part baffles me
[21:31:58] <Firebrand9> I even, for the sake of purity, blew away the entire Local Settings\Application Data\Exult DIR, and let it create it from scratch, but the results were the same
[21:33:19] <Firebrand9> here's the stdout.txt : http://pastebin.com/yiyEi5fb
[21:35:38] <Marzo> Pastebin is saying that this paste does not exist
[21:36:41] <Firebrand9> it does all that and instantly stops. I see a window for a 1/4 second and then it bails out
[21:36:54] <Firebrand9> try again. I'll repost if not
[21:37:44] <Marzo> Same thing
[21:38:40] <Firebrand9> http://pastebin.com/VBd5ZLYE
[21:39:03] <Firebrand9> http://pastebin.com/VBd5ZLYE
[21:39:45] <Marzo> I guess pastebin doesn't want to cooperate
[21:40:04] <Firebrand9> the heck? Still?
[21:40:14] <Marzo> "The specified bucket does not exist"
[21:40:18] <Firebrand9> you could see the others?
[21:40:47] <Marzo> Hrm. I just tried to reload the other and it failed with the same name
[21:40:50] <Marzo> *error
[21:40:58] <Marzo> So it may be a DNS caching issue
[21:41:51] <Marzo> Yep, that was it: cleared cache and it shows now
[21:43:51] <Firebrand9> ok, great, I was about to try an alternative
[21:45:15] <Marzo> Hrm
[21:45:18] <Marzo> "Looking for 'serpentisle' at 'D:\Games\Ultima VII\Ultima 7\Part 2'... found game with identity 'FORGE'"
[21:45:21] <Marzo> That is wrong
[21:45:50] <Firebrand9> what's that mean? The game plays
[21:46:09] <Firebrand9> (without the local .cfg file)
[21:46:26] <Marzo> Does SI play? Because that game identity is wrong
[21:46:36] <Firebrand9> I'll verify
[21:46:40] <Firebrand9> brb
[21:47:02] <Marzo> It should be either 'SERPENT ISLE' or 'SILVER SEED'
[21:47:39] <Marzo> Of course, this is highly unlikely to be the problem, it is just something I noticed
[21:48:11] <Firebrand9> it sure does play
[21:48:28] <Firebrand9> no problems
[21:49:18] <Marzo> That is without the specified config, right?
[21:49:26] <Firebrand9> correct
[21:49:38] <Marzo> The sdtout appears correct for this case?
[21:49:54] <Firebrand9> I'll post it
[21:50:53] <Firebrand9> http://pastebin.com/7f6pCV2D
[21:51:02] <Firebrand9> it appears fine
[21:57:02] <Marzo> It does appear fine
[21:57:24] <Marzo> What is interesting is that the other one is incorrect
[22:00:18] <Firebrand9> this is getting a little hard to keep track of, so for the sake of confirmation I'll post the one that does not run again
[22:00:50] <Marzo> Is the "default" config file used by Exult equal to the modified on you are trying to use?
[22:01:54] <Firebrand9> http://pastebin.com/MbNEc7Yz
[22:02:10] <Firebrand9> I haven't done a file compare on them, so I don't know
[22:03:37] <Marzo> Can you post it then?
[22:04:07] <Firebrand9> the one in Local Settings\Application Data\Exult?
[22:04:12] <Marzo> By "default" I mean the one that gets used when you don't specify the config file in the command line
[22:04:15] <Marzo> Yes
[22:05:16] <Firebrand9> http://pastebin.com/7M92Y3rv
[22:06:13] <Marzo> Oo:
[22:06:14] <Marzo>     <static_path>    D:\Games\Ultima VII\Ultima 7\static    </static_path>
[22:06:22] <Marzo> In the SI section
[22:07:02] <Marzo> Again, unlikely to be the problem at hand, but explains the issue I mentioned earlier
[22:07:03] <Firebrand9> in the ./ version?
[22:07:49] <Firebrand9> the odd part about that is I added that when it said it couldn't find the static data
[22:08:24] <Marzo> Now it is finding the wrong one :-p
[22:08:48] <Marzo> I see you have all BG and SI mods in the same folder
[22:09:01] <Marzo> I have no idea if this is a good idea or not
[22:09:07] <Firebrand9> what DIR?
[22:09:48] <Marzo> <mods> D:\Games\Ultima VII\Exult_1.x\mods </mods>
[22:10:08] <Firebrand9> right
[22:10:31] <Firebrand9> hmm, that's easily fixed
[22:11:52] <Firebrand9> it didn't run prior to that being added though. This issue preceded that
[22:13:54] <Firebrand9> now they're in D:\Games\Ultima VII\Exult_1.x\mods\Part_1 and 2 respectively
[22:19:44] <Marzo> Out of curiosity, can you try running this: exult.exe --nocrc --fov -c "D:\Games\Ultima VII\Exult_1.x\exult.cfg"
[22:19:58] <Firebrand9> sure
[22:21:14] <Firebrand9> huh. That works, sort of. It runs the Black Gate in a window
[22:22:29] <Marzo> Well, the config you posted had fullscreen set to no
[22:22:55] <Firebrand9> ok
[22:23:17] <Firebrand9> if I use the --si option, it runs Black Gate also
[22:23:22] <Marzo> Hm. So the Exult menu is crashing
[22:23:35] <Marzo> Did you fix the static path for SI?
[22:23:38] <Firebrand9> interesting. But why?
[22:23:46] <Firebrand9> let me go do that
[22:24:52] <Marzo> Oh, I see
[22:25:00] <Marzo> This is likely what is causing the issues, after all
[22:25:16] <Firebrand9> ok, that fixed SI running
[22:26:06] <Marzo> Can you try running the menu now?
[22:26:08] <Firebrand9> hmm it appears to not be the cause
[22:26:18] <Firebrand9> I just did, and it would not run
[22:26:35] <Marzo> Hrm
[22:27:35] <Firebrand9> I can get either to run (in Fullscreen or Windowed) with the command line options
[22:27:46] <Firebrand9> but if I remove that, it won't work
[22:30:08] <Firebrand9> here's the current std*.txt files : http://pastebin.com/rfH2iKyM
[22:33:53] <Marzo> Well, there is obviously a bug in Exult, but it doesn't help that I can't reproduce this
[22:34:06] <Marzo> Passing the config file as a parameter is working perfectly
[22:34:27] <Marzo> Of course I am on Linux, but I don't think this is the reason
[22:34:55] <Marzo> Hm
[22:35:11] <Marzo> Do you have the *.flx files on D:\Games\Ultima VII\Data
[22:35:31] <Marzo> (this is just a sanity check, by the way)
[22:35:59] <Firebrand9> yes, I can take a screenshot if you need to confirm
[22:36:22] <Marzo> No, I'll take your word for it
[22:37:01] <Marzo> It is just always good to make sure that it is something that "is so basic, it can't *possibly* be overlooked" wasn't, in fact, overlooked
[22:37:07] <Firebrand9> exult.flx, exult_bg.flx, exult_si.flx, jmsfx.flx, jmsisfx.flx are there
[22:37:17] <Marzo> (you'd be surprised at how often that turns out to be the case)
[22:37:19] <Firebrand9> right, usually it's the basic things
[22:37:42] <Firebrand9> I program games also, so believe me, I know
[22:37:50] <Firebrand9> it's often something dumb
[22:39:43] <Marzo> My data dir also shows bg_mr_faces.vga and bg_paperdol.vga in that dir, but that is likely to be an issue only when playing a BG or FoV game with paperdolls on
[22:40:54] <Marzo> And exultmsg.txt too
[22:41:05] <Marzo> Hm. Why is exult_iphone.flx there too?
[22:41:22] <Marzo> Bah, this is irrelevant for the problem at hand
[23:02:21] <Firebrand9> hmm I don't know
[23:08:30] --> Kirben has joined #exult
[23:08:30] --- ChanServ gives channel operator status to Kirben
[23:16:09] <Firebrand9> any more ideas Marzo?
[23:16:19] <Marzo> No
[23:16:30] <Firebrand9> a bug then?
[23:17:28] <Marzo> An annoying one I can't reproduce
[23:20:12] <Firebrand9> is there any other info I can give you? Upload the DIR?
[23:25:02] <Firebrand9> brb
[23:25:03] <-- Firebrand9 has left IRC (Quit: ChatZilla 0.9.90.1 [Firefox 8.0.1/20111120135848])
[23:25:33] --> Firebrand9 has joined #exult