#exult@irc.freenode.net logs for 25 Jul 2010 (GMT)

Archive Today Yesterday Tomorrow
Exult homepage


[00:21:13] --> Kirben has joined #exult
[00:21:13] --- ChanServ gives channel operator status to Kirben
[00:40:49] <-- Cahaan has left IRC ()
[03:03:34] --> julien has joined #exult
[03:03:40] <-- julien_ has left IRC (Ping timeout: 245 seconds)
[05:35:45] <-- Marzo has left IRC (Ping timeout: 240 seconds)
[06:27:38] <-- Kirben has left IRC ()
[06:59:08] --> Kirben has joined #exult
[06:59:08] --- ChanServ gives channel operator status to Kirben
[07:20:51] <-- Rottingbeef has left IRC (Ping timeout: 265 seconds)
[08:06:38] --> Rottingbeef has joined #exult
[08:13:57] <-- Rottingbeef has left IRC ()
[13:42:49] --> Marzo has joined #exult
[13:58:27] --> Cahaan has joined #exult
[14:08:04] <-- Kirben has left IRC ()
[15:23:41] <wjp> Colourless: are you around?
[15:25:57] <wjp> or Marzo ?
[15:26:20] <wjp> or anybody familiar with exult's audio? :-)
[16:15:17] <Marzo> I am here
[16:15:23] --> Dominus has joined #exult
[16:15:24] --- ChanServ gives channel operator status to Dominus
[16:15:25] <Marzo> Maybe I can help, I don't know
[16:15:57] <Marzo> (although depending on the issue, it may require Colourless)
[16:45:15] <-- Colourless has left IRC (Quit: casts improved invisibility)
[16:46:09] <wjp> Marzo: I was looking at the restarting music bug, and it seems like it's a regression from your (fairly) recent load_timbre change
[16:47:40] <wjp> I've made a short note about it on the bug report
[16:49:16] --> Colourless has joined #exult
[16:49:16] --- ChanServ gives channel operator status to Colourless
[16:57:47] <Marzo> Ah, I see what was wrong
[16:57:54] <Marzo> Fixed it the proper way now
[17:03:00] <-- Marzo has left IRC (Ping timeout: 265 seconds)
[17:03:39] --> Marzo has joined #exult
[17:51:46] <wjp> Marzo: great, thanks
[21:18:55] --> ettin has joined #exult
[23:18:06] <Dominus> hmm, I now have a real PPC mac here that I want to use to build and test ppc builds of Exult. Running ./configure I get
[23:18:08] <Dominus> configure: error: conditional "AMDEP" was never defined.
[23:18:08] <Dominus> Usually this means the macro was only invoked conditionally.
[23:18:32] <Dominus> an OLD thing about this I found is http://osdir.com/ml/sysutils.autoconf.bugs/2002-10/msg00088.html
[23:33:34] <Dominus> wjp, marzo do you have any idea on this? Fingolfin complained about this as well back in july 2008 http://sourceforge.net/mailarchive/forum.php?thread_name=20080713083852.GA32214%40math.leidenuniv.nl&forum_name=exult-general
[23:34:53] <Dominus> autoconf 2.65 and automake 1.11.1
[23:36:22] <wjp> I don't know if Max ever mailed me his configure script. Could you mail me yours?
[23:37:29] <Dominus> yes, will do that, along with the log
[23:39:01] <Dominus> I didn't really expect a reply at this hour :)
[23:39:21] <wjp> I should be in bed, yes :-)
[23:39:40] <Dominus> :)
[23:39:43] <Dominus> me too
[23:40:08] <Dominus> I just wanted to setup this ppc mac mini for compiling...
[23:40:12] <Dominus> just...
[23:40:13] <Dominus> :)
[23:40:37] <wjp> configure:5981: checking dependency style of /usr/bin/gcc-4.0
[23:40:37] <wjp> configure:6091: result: none
[23:40:39] <wjp> hmm
[23:45:45] <Dominus> oh
[23:45:57] <Dominus> that is now happening on my intel machine as well
[23:46:14] <Dominus> did marzo's changes today cause this?
[23:46:31] <Marzo> I doubt it
[23:46:40] <Dominus> I didn't have problems with building exult before that...
[23:46:41] <Marzo> (works fine here)
[23:48:42] <wjp> can you try, in a terminal in exult's root dir:
[23:48:49] <wjp> mkdir sub
[23:48:58] <wjp> echo '#include <stdio.h>' > sub/test.c
[23:49:12] <wjp> source=sub/test.c object=sub/test.o depmode=gcc depfile=sub/test.Po ./depcomp gcc -c sub/test.c -o sub/test.o
[23:49:55] <Dominus> yes
[23:49:55] <wjp> and then see if that gives error messages and if sub/test.Po looks "ok"?
[23:50:22] <Dominus> no error
[23:50:43] <Dominus> http://pastebin.com/SsNhDcdX
[23:52:09] <wjp> ah well, that would've been too easy
[23:52:32] <wjp> oh, wait, replace 'gcc' with /usr/bin/gcc-4.0
[23:52:40] <wjp> (the 'gcc' after ./depcomp)
[23:52:40] <Dominus> on the ppc machine I get depcomp: Variables source, object and depmode must be set
[23:53:14] <wjp> try putting an 'env ' in front of the entire command
[23:54:19] <Dominus> that worked on the ppc
[23:54:55] <wjp> ah well
[23:55:45] <wjp> I should be going
[23:55:58] <wjp> remind me later to have another look :-)
[23:56:04] <Dominus> I will :)
[23:56:06] <wjp> good night
[23:56:10] <Dominus> thanks and good night
[23:56:33] <Dominus> I'm really wondering why it suddenly fails on my intel machine as well nbow
[23:57:32] <Marzo> Well, we can test
[23:57:46] <Marzo> Try deleting line 68 of configure.ac
[23:58:46] --> Kirben has joined #exult
[23:58:46] --- ChanServ gives channel operator status to Kirben