#exult@irc.freenode.net logs for 29 Nov 2009 (GMT)

Archive Today Yesterday Tomorrow
Exult homepage


[00:58:22] <-- Kirben has left IRC ()
[01:08:21] --> Kirben has joined #exult
[01:08:21] --- ChanServ gives channel operator status to Kirben
[02:37:36] --> MissCleo has joined #exult
[02:44:30] <-- Sevalecan has left IRC ("Leaving")
[02:44:32] --- MissCleo is now known as Sevalecan
[12:06:27] --> pupnik has joined #exult
[12:22:16] <-- pupnik_ has left IRC (Read error: 110 (Connection timed out))
[12:27:32] --> Dominus has joined #exult
[12:27:36] --- ChanServ gives channel operator status to Dominus
[12:59:51] <-- Kirben has left IRC ()
[14:39:17] <-- Colourless has left IRC ("casts improved invisibility")
[15:25:51] --> Marzo has joined #exult
[15:35:57] --- Marzo is now known as Marzo_away
[15:58:27] <-- Dominus has left IRC ("Leaving.")
[17:11:36] --> Fingolfin has joined #exult
[17:11:36] --- ChanServ gives channel operator status to Fingolfin
[19:15:01] <-- Fingolfin has left IRC ()
[19:19:24] --> Dominus has joined #exult
[19:19:31] --- ChanServ gives channel operator status to Dominus
[19:27:33] <-- Sevalecan has left IRC (Remote closed the connection)
[19:28:02] --> Sevalecan has joined #exult
[21:07:18] <-- Dominus has left IRC ("Leaving.")
[21:07:24] --> Dominus has joined #exult
[21:07:37] <-- Dominus has left IRC (Remote closed the connection)
[21:07:48] --> Dominus has joined #exult
[21:07:49] --- ChanServ gives channel operator status to Dominus
[21:34:54] --> Colourless has joined #Exult
[21:34:54] --- ChanServ gives channel operator status to Colourless
[22:04:08] <-- Dominus has left IRC ("Leaving.")
[22:38:24] --> wepy has joined #exult
[22:38:28] <wepy> ;D
[22:39:17] <wepy> does exult work on openbsd?
[22:42:06] <wjp> it should
[22:43:54] <wepy> ;D
[22:50:21] <wepy> i wonder if EA will ever make another Ultima
[22:55:57] --> eXult^infidel has joined #exult
[22:56:51] <-- eXult^infidel has left #exult ()
[23:03:35] <wepy> can't build it on openbsd :(
[23:03:51] <wjp> what goes wrong?
[23:05:15] <wepy> looks like the final linking failed. Shall I pastebin it?
[23:06:23] <wepy> http://pastebin.com/d75aea3eb
[23:07:02] <wepy> i can't tell why it says it can't find the library `'
[23:07:50] <wjp> could be a problem in one of the .la files
[23:08:05] <wjp> could you take a look inside them to see if anything looks fishy?
[23:08:28] <wjp> it might also be worth it to try latest svn instead of 1.2
[23:08:48] <wjp> (1.2 is ancient, but we sadly never got around to doing a release afterwards)
[23:12:20] <wepy> i can try svn, 1 min
[23:14:40] <wepy> what do i need to type to download your svn tree?
[23:15:06] <wjp> svn checkout https://exult.svn.sourceforge.net/svnroot/exult/exult/trunk exult
[23:19:06] <wepy> this might take a while ;)
[23:19:17] <wepy> in the mean time, what could i look for inside of the .la files that would be weird?
[23:19:38] <wjp> something that looks like it could cause that empty library name in the error
[23:20:03] <wepy> im thinking whitespace?
[23:20:07] <wjp> how did you get the 1.2 sources, by the way?
[23:20:15] <wepy> just grabbed it from the sf page
[23:20:21] <wjp> the .tar.gz or the .zip?
[23:20:25] <wepy> tgz
[23:20:28] <wjp> ok
[23:20:49] <wjp> (with the .zip there may have been some dos endline issues)
[23:21:01] <wepy> ic
[23:21:24] <wjp> you could also try running that libtool command leaving out half of the libraries at a time until you find which one triggers the error
[23:21:45] <wjp> (leaving them out will trigger other errors of course, but it could pinpoint the problem)
[23:23:02] <wepy> all of the .la files have lots of ='' fields
[23:23:13] <wepy> wjp: i'll give that a shot
[23:24:18] <wjp> I think dependency_libs is the main field to look at in the .la
[23:30:24] <wepy> removed all .la files from the line and got the same error
[23:30:42] <wepy> maybe it's one of the other parts at the end
[23:32:47] <wepy> appears to be -lSDL
[23:34:09] <wepy> take that back..
[23:36:38] <wepy> -lSDL and -lSDL_mixer (i have both of these installed)
[23:36:42] <wepy> maybe it's a path issue?