#exult@irc.freenode.net logs for 3 Nov 2016 (GMT)

Archive Today Yesterday Tomorrow
Exult homepage


[00:24:12] <-- Marzo has left IRC (Quit: Leaving)
[00:33:06] --> frob_bizaro has joined #exult
[00:33:40] <-- frob_bizaro has left IRC (Remote host closed the connection)
[00:34:14] --> frob_bizaro has joined #exult
[00:36:26] <-- frob has left IRC (Ping timeout: 260 seconds)
[00:38:39] <-- frob_bizaro has left IRC (Ping timeout: 250 seconds)
[00:54:27] <tsoliman> it took me a long time to realize I can't "mkdir build; cd build; ../configure --with-sdl=sdl2; make"
[00:55:13] <tsoliman> building in the same directory now - had to install pkgconfig via macports (which I hope doesn't backfire when building other stuff)
[01:00:04] <tsoliman> ok so I upgraded to 2.0.5 and removed my patch .. sure enough .. rebuilding scummvm doesn't show the warning and neither does exult .. however .. exult isn't seeing the sound packs
[01:00:34] <tsoliman> s/my patch/my portfile/ ... it's really your patch :)
[01:07:37] <tsoliman> I replaced just the binary /Applications/Exult.app/Contents/MacOS/ with the one I built and it works now .. I was under the impression that I could just run it in-tree
[01:12:26] <tsoliman> ah .. make bundle ; open Exult.app
[02:59:36] <-- Dominus has left IRC (Ping timeout: 260 seconds)
[03:00:06] --> Dominus has joined #exult
[03:00:06] <-- Dominus has left IRC (Changing host)
[03:00:06] --> Dominus has joined #exult
[03:00:06] --- ChanServ gives channel operator status to Dominus
[03:05:12] <-- Dark-Star has left IRC (Remote host closed the connection)
[03:05:40] --> Dark-Star has joined #exult
[03:29:01] --> frob has joined #exult
[03:56:44] <-- frob has left IRC (Remote host closed the connection)
[06:54:05] <-- Dominus has left IRC (Ping timeout: 250 seconds)
[06:54:34] --> Dominus has joined #exult
[06:54:34] <-- Dominus has left IRC (Changing host)
[06:54:34] --> Dominus has joined #exult
[06:54:34] --- ChanServ gives channel operator status to Dominus
[08:40:27] <-- Lightkey has left IRC (Ping timeout: 260 seconds)
[08:52:35] --> Lightkey has joined #exult
[09:49:56] <Dominus> working?
[10:17:49] --> Marzo has joined #exult
[16:06:07] --> frob has joined #exult
[16:07:17] <-- frob has left IRC (Read error: Connection reset by peer)
[16:07:38] --> frob has joined #exult
[16:09:36] --> frob_bizaro has joined #exult
[16:11:42] --- frob_bizaro is now known as frob_
[16:12:13] <-- frob has left IRC (Ping timeout: 250 seconds)
[16:22:10] <-- Rottingbeef has left IRC ()
[16:25:09] --> Rottingbeef has joined #exult
[23:13:24] <Marzo> Dominus, tsoliman: OpenGL also has the issue of not dong xforms correctly: it uses plain alpha composition, which gives inaccurate results
[23:14:19] <Marzo> The "right" way would be to do a shader; I have been meaning to do this for years, but never went around to it
[23:38:21] <tsoliman> Dominus: yes working :) thanks again - you can now safely upgrade to 2.0.5 I guess