#exult@irc.freenode.net logs for 5 Feb 2004 (GMT)

Archive Today Yesterday Tomorrow
Exult homepage


[00:51:29] --> Kirben has joined #exult
[00:51:29] --- ChanServ gives channel operator status to Kirben
[03:00:03] <-- static has left IRC (Read error: 104 (Connection reset by peer))
[03:53:22] --> servus has joined #exult
[05:06:56] --> SB-X has joined #exult
[07:14:07] --> MrP2003 has joined #exult
[07:21:37] <-- MisterP has left IRC (Read error: 60 (Operation timed out))
[07:31:06] --> CaliMonk has joined #exult
[07:31:15] <CaliMonk> hello
[07:34:04] <SB-X> hi
[07:51:12] <CaliMonk> Does anyone know if there's ever going to be a PalmOS version of Exult :]
[07:52:42] <Darke> Unlikely. Last time I checked the various palms didn't have enough memory to run it, or cpu power.
[07:55:39] <CaliMonk> i see
[07:55:42] <CaliMonk> odd
[07:56:06] <CaliMonk> I have a PalmOS version of ScummVM which runs all LEC games just fine, i can't imagine Ultima being 'heavier' then those games
[07:58:00] <CaliMonk> anyway its a shame i'd love to play Ultima on my Clie
[07:58:33] <Darke> The original ultima, no. One 'problem' is that exult is not really ultima as such. It was originally designed to be a map viewer, and it's feature set kind of grew. *grin* It doesn't do 'nice' things like use the hdd as virtual memory, rather loads all the data into memory at runtime. It's also not at all afraid to things the easy way at the expense of performance and code/memory size.
[07:59:36] <Darke> It's also not designed to run on x86 processors only, which the original one was, which adds quite a bit of overhead. If the palm's cpu isn't little endian, you've also got significant overhead as it translates the data into native byte format too.
[07:59:45] <-- SB-X has left IRC (Read error: 60 (Operation timed out))
[08:00:30] <Darke> (Which you can get away with 'inlining' if you're using x86 only, which we don't do beacause we're not looking for extreme performance, exult runs fine on almost any cpu up to 4 years old.)
[08:07:11] <CaliMonk> ic
[08:20:54] <-- servus has left IRC ("Client exiting")
[08:38:14] --> servus has joined #exult
[08:38:32] * servus kicks his kernel and kurses
[08:50:12] <-- servus has left IRC ("Client exiting")
[08:50:47] --> servus has joined #exult
[08:51:06] <servus> It workses, my preeecious!
[08:51:08] <servus> Almost
[09:10:18] --> SB-X has joined #exult
[09:25:31] <-- servus has left IRC (Remote closed the connection)
[09:29:34] --> servus has joined #exult
[09:31:57] --- SB-X is now known as sbx|afk
[09:51:56] <-- MrP2003 has left IRC (Read error: 54 (Connection reset by peer))
[09:51:57] --> MrP2003 has joined #exult
[09:54:58] --> MrP67206 has joined #exult
[10:11:14] <-- MrP2003 has left IRC (Connection timed out)
[12:09:04] --> sbx has joined #exult
[12:09:04] <-- sbx|afk has left IRC (Read error: 54 (Connection reset by peer))
[13:47:43] --> Colourless has joined #Exult
[13:47:48] --- ChanServ gives channel operator status to Colourless
[13:48:06] --> Mykael has joined #exult
[13:48:08] <Colourless> hi
[13:48:16] <Mykael> hello?
[13:48:42] <Mykael> got a problem with Exult Tools, if someone can help me
[13:49:14] <Mykael> I get this error when trying to use ucxt : "Assertion failed: otd.opcode!=0x00, file usecode/ucxt/src/ucfunc.cc, line 1035"
[13:50:18] <Mykael> had a read of the logs and found other ppl with the same problem, but I cant seem to fix it. I have all the .data files in the /data dir, except u7opcodes.data - instead there is a file called opcodes.txt
[13:52:08] <Mykael> hmm.
[13:58:32] <Mykael> o.....kay
[13:58:36] <-- Mykael has left IRC ()
[14:00:26] <-- sbx has left IRC (Read error: 60 (Operation timed out))
[14:01:55] <Colourless> Darke! Support your software! :-)
[14:15:10] --> Mykael has joined #exult
[14:15:19] <Mykael> hey, its okay, figured it out myself
[14:15:34] <Mykael> ahh... thanks anyway... yeah
[14:15:40] <-- Mykael has left IRC (Client Quit)
[14:54:48] <-- Kirben has left IRC ("System Meltdown")
[15:21:27] <wjp> hi
[15:21:48] * wjp wonders why people never tell afterwards what exactly the problem was
[15:22:18] <wjp> that would be why he found other people with the same problem in the logs, but not the solution :-)
[15:23:30] <wjp> (although in this case it appears to be a missing u7opcodes.data)
[16:10:50] <Colourless> hi wjp
[17:20:27] --> t12 has joined #exult
[17:22:06] <t12> hey, wondering if i can get some help setting up music with exult 1.0 in freebsd?
[17:22:20] <wjp> hi
[17:22:27] <wjp> hm, 1.0?
[17:22:39] <t12> i couldnt get 1.1etc to build properly
[17:22:47] * t12 checks for an update in ports
[17:23:33] <wjp> if 1.1.9rc1 doeesn't build in freebsd, it might be nice to fix the problem
[17:23:43] <t12> i'm glad to assist where i can
[17:24:47] <t12> let me cvsup ports and see if someone else did before me first :)
[17:26:06] <t12> btw
[17:26:06] <t12> thanks for writing exult
[17:26:06] <t12> having to set up an old dos machine to get a u7 fix is quite a chore
[17:28:03] <t12> nope, looks like 1.00 is still whats in ports
[17:33:00] <wjp> what is the problem with the 1.1.9rc1 build?
[17:33:06] <t12> building right now
[17:33:12] <t12> take a bit to get to it
[17:33:21] <t12> first thing is with SDL_mixer, but thats more of ports being ewird
[17:33:22] <t12> weird
[17:33:35] <t12> it only installs SDL_mixer.h in /usr/local/include/SDL11
[17:33:49] <t12> but thats just a portsism
[17:36:39] <t12> here we go
[17:36:57] <t12> mind me just pasting the errors
[17:37:13] <wjp> not at all :-)
[17:37:41] <t12> if g++ -DHAVE_CONFIG_H -I. -I. -I. -I. -I./headers -I./imagewin -I./shapes -I./server -I./data -I./objs -I./conf -I./files -I./gumps -I./audio -I./pathfinder -I./usecode -I/usr/local/include/SDL -D_REENTRANT -D_THREAD_SAFE -DXWIN -O2 -Wno-long-long -DEXULT_DATADIR=\"/usr/local/share/exult\" -g -O2 -MT exult.o -MD -MP -MF ".deps/exult.Tpo" -c -o exult.o `test -f 'exult.cc' || echo './'`exult.cc; then mv -f ".deps/exult.Tpo" ".deps/exult.Po"; else
[17:37:41] <t12> In file included from exult.cc:38:
[17:37:41] <t12> In file included from exult.cc:38:
[17:37:46] <t12> hurrr pasting slashes
[17:37:49] <t12> In file included from exult.cc:38:
[17:37:52] <t12> /usr/local/include/SDL/SDL_syswm.h:55:22: X11/Xlib.h: No such file or directory
[17:37:55] <t12> /usr/local/include/SDL/SDL_syswm.h:56:23: X11/Xatom.h: No such file or directory
[17:37:58] <t12> etc
[17:38:06] <t12> actually this just looks like the lack of include paths
[17:38:09] <wjp> that kind of looks like an SDL problem
[17:39:44] <t12> ah yup
[17:40:00] <t12> i just added a -I/usr/X11R6/include to the SDL cflags line
[17:40:09] <t12> in the generated makefile, and thats fixed
[17:40:09] <wjp> btw, our configure adds that -I on openbsd
[17:40:14] <t12> ah
[17:40:17] <wjp> I could add it in freebsd too
[17:40:55] <t12> continuing build...
[17:41:24] <t12> ok done
[17:41:25] <t12> heh
[17:41:31] <t12> i guess i was not in a patient mood
[17:41:31] <wjp> hm, I wonder why autogen.sh isn't included in the .tar.gz
[17:41:36] <t12> when i tried to build it last night
[17:43:39] <t12> on make install:
[17:43:43] <t12>
[17:43:43] <t12> make: don't know how to make install-exec-local. Stop
[17:43:43] <t12> *** Error code 2
[17:43:48] <t12> /usr/bin/install -c exult /usr/local/bin/exult
[17:43:51] <t12> damned slashes again.
[17:44:26] <t12> /usr/bin/install -c exult /usr/local/bin/exult
[17:44:26] <t12> make: don't know how to make install-exec-local. Stop
[17:44:26] <t12> *** Error code 2
[17:44:29] <t12> is how that should have read.
[17:44:50] <wjp> in which directory was make at that point?
[17:45:17] <wjp> hm, I think I see a possible problem
[17:45:36] <t12> unsure.. where would i find that
[17:45:40] <t12> it shows Stop in /usr/home/t12/tmp/exult-1.1.9rc1.
[17:48:11] * wjp hmms
[17:50:07] <wjp> yes, I know what's causing this
[17:50:12] <wjp> using gmake should work
[17:50:18] <wjp> but I'll add a fix to cvs
[17:50:19] <t12> attempting
[17:50:37] <t12> yup, that works
[17:50:49] <t12> also, its sort of unclear as to where the music oggs should live in unxi?
[17:50:50] <t12> er
[17:50:51] <t12> unix?
[17:51:44] <wjp> if you run exult it should tell you the location it's looking
[17:52:01] <wjp> (1.1.9rc1 will, anyway)
[17:52:25] <t12> ah nod
[17:52:31] <wjp> I think the default is a subdirectory 'music' of the exult data dir
[17:52:52] <t12> is this adjustable in the config?
[17:52:58] <wjp> yes
[17:53:21] <wjp> config/disk/music_path
[17:53:31] --> Andersen has joined #exult
[17:56:32] <t12> and erm
[17:56:45] <t12> how do you explicitly specify to use that rather then timidity?
[17:57:07] <wjp> in the in-game config screen, go to audio options and choose "digital" as the driver
[17:58:49] <t12> aweoms
[17:58:50] <t12> e.
[18:00:02] <t12> excelent
[18:00:06] <t12> thanks much :)
[18:00:08] <-- MrP67206 has left IRC ("SIGSEGV")
[18:00:16] --> MisterP has joined #exult
[18:00:56] <wjp> if I send you a new configure.ac and Makefile.am, could you check if it works properly then?
[18:01:22] <-- MisterP has left IRC (Read error: 54 (Connection reset by peer))
[18:01:24] --> MisterP has joined #exult
[18:01:43] <t12> sure
[18:02:21] <wjp> http://www.math.leidenuniv.nl/~wpalenst/{configure.ac,Makefile.am}
[18:02:58] <t12> building
[18:03:41] <t12> heh
[18:03:42] <t12> WARNING: `aclocal-1.7' is missing on your system.
[18:03:52] <t12> lemme install things
[18:04:08] <wjp> which automake/autoconf do you have?
[18:04:31] <t12> autoconf (GNU Autoconf) 2.53
[18:04:33] <wjp> (1.7 is not strictly necessary, I think; 1.5 or 1.6 should work too, but you need to run autogen.sh to regenerate various things)
[18:04:52] <t12> no automake :)
[18:04:54] <t12> building
[18:06:09] <t12> aclocal.m4:39: error: Autoconf version 2.54 or higher is required
[18:06:10] <t12> heh
[18:06:25] <wjp> 2.53 should be fine
[18:06:30] <wjp> just run autogen.sh
[18:07:26] <t12> no autogen.sh present?
[18:07:38] <wjp> http://www.math.leidenuniv.nl/~wpalenst/autogen.sh
[18:07:52] <wjp> it was accidentally missing from the release tarball :/
[18:08:39] <t12> all kinds of errors from autogen
[18:08:47] <t12> no libtoolize mainly
[18:08:57] <wjp> ah, yes, you need libtool
[18:09:16] <t12> installing
[18:09:22] <wjp> sorry about all this :-)
[18:09:31] <t12> heh np, this machine just hasnt been geared for development
[18:09:40] <t12> or at least not this form
[18:10:50] <wjp> hm, dinner's ready; I'll be back later
[18:10:56] <t12> ok
[18:11:00] <t12> i still get
[18:11:00] <t12> configure.ac:29: warning: do not use m4_patsubst: use patsubst or m4_bpatsubst
[18:11:00] <t12> configure.ac:143: warning: AC_PROG_LEX invoked multiple times
[18:11:00] <t12> configure.ac:767: warning: do not use m4_regexp: use regexp or m4_bregexp
[18:11:16] <wjp> a few warnings should be ok
[18:11:19] <t12> i'll be around, beep me
[18:11:40] <wjp> if you get any errors, just paste them into the channel
[18:14:01] <t12> ./ltconfig: ./ltconfig: No such file or directory
[18:14:01] <t12> configure: error: libtool configure failed
[18:14:04] <t12> ltconfig exists out of path
[18:14:07] <t12> but not in .
[18:15:04] <t12> other questions: is there a way to disable autopose when switching x11 focus?
[18:23:46] <t12> pause even
[18:33:11] <wjp> back
[18:33:51] <wjp> hm, ltconfig?
[18:35:09] <wjp> which libtool version do you have?
[18:42:26] --> Dark-Star has joined #exult
[18:45:24] <t12> 1.3 4 and 5, but none are in path ala ports
[18:46:37] <t12> but the exec failed on running it from ./?
[18:47:57] <wjp> I think ltconfig is no longer used in libtool > 1.3
[18:49:02] <t12> er
[18:49:03] <t12> yes
[18:49:14] <t12> bash-2.05b$ find /usr/local -name ltconfig
[18:49:17] <t12> /usr/local/share/libtool13/ltconfig
[18:50:35] <-- MisterP has left IRC (Read error: 104 (Connection reset by peer))
[18:57:43] <wjp> so it was using libtool 1.3, right?
[18:58:09] --> MisterP has joined #exult
[19:03:19] <t12> er,
[19:03:21] * t12 confused
[19:27:15] <wjp> anyway, it looks like things will work fine now as long as you already have a pre-generated configure & co.
[19:27:50] <wjp> (I added the -I/usr/X11R6/include and I'm fairly sure my change to the Makefile will have fixed the 'make install' problem)
[19:37:08] <-- Colourless has left IRC ("casts invisibility")
[19:50:29] <-- MisterP has left IRC (Read error: 104 (Connection reset by peer))
[20:01:51] --> MisterP has joined #exult
[20:03:12] <-- Florent has left IRC (sterling.freenode.net irc.freenode.net)
[20:08:31] --> Florent has joined #exult
[20:31:15] --> Dominus has joined #exult
[20:31:19] --- ChanServ gives channel operator status to Dominus
[20:31:45] <Dominus> hi
[20:31:51] <MisterP> howdy
[20:31:52] <wjp> hi
[20:37:34] <wjp> bbl
[20:43:45] <-- MisterP has left IRC (Remote closed the connection)
[20:45:54] <-- Andersen has left IRC (Nick collision from services.)
[20:46:06] --> Andersen has joined #exult
[20:57:39] <-- servus has left IRC (Remote closed the connection)
[20:58:45] --> Fingolfin has joined #exult
[20:58:45] --- ChanServ gives channel operator status to Fingolfin
[21:00:44] <Dominus> hi Florent
[21:00:48] <Dominus> oops
[21:00:51] <Dominus> hi Fingolfin
[21:05:36] <Fingolfin> hiya Dominus
[21:24:53] <wjp> hi Max
[21:31:19] <Florent> hi Dominus :P
[21:31:22] <Florent> oops
[21:31:27] <Florent> hi Dominus :)
[21:31:59] <Dominus> :-)
[21:43:55] <-- Dominus has left IRC (Read error: 54 (Connection reset by peer))
[21:52:38] <-- Florent has left IRC ()
[21:55:15] --> Cahaan has joined #exult
[22:08:58] --> MisterP has joined #exult
[22:31:16] <-- Fingolfin has left IRC ("42")
[22:44:06] <-- wjp has left IRC (Remote closed the connection)
[22:48:32] --> wjp has joined #exult
[22:52:01] --- ChanServ gives channel operator status to wjp
[22:54:17] --> exultbot has joined #exult
[22:54:17] --- Topic for #exult is: Exult: an open-source engine for Ultima 7. http://exult.sf.net/
[22:54:17] --- Topic for #exult set by wjp at Tue Jan 6 09:55:17 2004
[23:26:02] <-- wjp has left IRC (Remote closed the connection)
[23:28:39] --> wjp has joined #exult
[23:28:39] --- ChanServ gives channel operator status to wjp
[23:34:28] <-- t12 has left IRC ("Leaving")