#gemrb@irc.freenode.net logs for 14 Jul 2010 (GMT)

Archive Today Yesterday Tomorrow
GemRB homepage


[02:34:00] --> raevol has joined #GemRb
[03:00:13] --> budlust has joined #GemRb
[03:35:34] <-- Gekz has left IRC (Ping timeout: 276 seconds)
[03:48:04] --> Gekz has joined #GemRb
[06:58:43] --> lynxlynxlynx has joined #GemRb
[06:58:44] --- ChanServ gives channel operator status to lynxlynxlynx
[07:06:00] <-- raevol has left IRC (Quit: Leaving.)
[07:08:38] <-- |Cable| has left IRC (Remote host closed the connection)
[07:12:03] <-- Gekz has left IRC (Quit: This computer has gone to sleep)
[07:34:14] --> SiENcE has joined #GemRb
[07:50:21] <-- budlust has left IRC (Quit: Lost terminal)
[08:41:35] --> budlust has joined #GemRb
[09:14:18] <-- budlust has left IRC (Ping timeout: 240 seconds)
[09:16:25] --> budlust has joined #GemRb
[09:27:05] <-- budlust has left IRC (Ping timeout: 265 seconds)
[09:28:49] --> budlust has joined #GemRb
[10:30:18] <-- budlust has left IRC (Ping timeout: 252 seconds)
[10:32:04] --> budlust has joined #GemRb
[10:56:33] <-- SiENcE has left IRC (Quit: @all: cya)
[12:24:21] <-- budlust has left IRC (Quit: leaving)
[12:36:57] --> Gekz has joined #GemRb
[13:38:33] <-- Gekz has left IRC (Quit: Leaving)
[13:53:38] --> budlust has joined #GemRb
[14:53:29] <Edheldil> lynxlynxlynx: I am reading some G3 thread at the moment.... if a release tarball lack configure, it's probably because it was built wrong - there's a target for that in Makefile by autotools and I guess in CMake's as well. Or was it just containing Cmaked Makefiles?
[14:54:38] <lynxlynxlynx> the tarball was generated with git
[14:54:47] <lynxlynxlynx> that means no autogen.sh
[14:55:28] <lynxlynxlynx> if someone wants to use the autotools bs, she can run it herself
[14:55:43] <lynxlynxlynx> cmake is now the default
[14:55:57] <lynxlynxlynx> the move to git just facilitates this
[16:17:38] <-- budlust has left IRC (Quit: Lost terminal)
[17:01:51] --> budlust has joined #GemRb
[17:24:58] <-- budlust has left IRC (Ping timeout: 276 seconds)
[17:26:08] --> budlust has joined #GemRb
[17:58:49] <lynxlynxlynx> buh, this heat is just numbing
[18:03:01] <CIA-23> GemRB: 03avenger_teambg * r696f3d21bf17 10gemrb/gemrb/core/GameScript/ (GameScript.cpp GameScript.h Triggers.cpp): added IsPathCriticalObject trigger
[18:05:49] <lynxlynxlynx> apparently not for everyone :)
[18:12:17] <wjp> we just had a fairly major thunderstorm here, so it's cooled down a bit now
[18:12:47] <fuzzie> http://www.xs4all.nl/~twijland/weerstation/data/OutsideTempHistory.gif <- same one that hit here, i expect
[18:13:10] <fuzzie> although not too hot in the first place
[18:20:43] <lynxlynxlynx> just crappy late day heat storm possibilities here
[18:20:55] <lynxlynxlynx> no cooldown and ruined plans
[18:21:32] --> Edheldil_ has joined #GemRb
[18:30:58] <CIA-23> GemRB: 03avenger_teambg * rcb28fe89b04e 10gemrb/gemrb/core/GameScript/ (Actions.cpp GameScript.cpp GameScript.h Triggers.cpp): added some LastMarkedSpell specific triggers and actions
[18:32:52] --> |Cable| has joined #GemRb
[18:38:24] <CIA-23> GemRB: 03avenger_teambg * rc09a9e0f63ae 10gemrb/gemrb/core/GameScript/GameScript.cpp: missing link
[18:50:54] --> Avenger has joined #GemRb
[18:51:01] --- ChanServ gives channel operator status to Avenger
[18:51:06] <Avenger> hi
[18:51:23] <lynxlynxlynx> ojla
[18:53:38] <CIA-23> GemRB: 03avenger_teambg * rd3c88732d8e7 10gemrb/gemrb/core/GameScript/ (Actions.cpp GameScript.cpp GameScript.h Triggers.cpp): added IsSpellTargetValid trigger
[18:53:45] <Avenger> adding some iwd2 scripting
[18:54:14] <Avenger> some parts are still a bit cloudy, or totally missing, but i see a lot of stuff clearer now
[18:54:56] <lynxlynxlynx> my endeavours are not so succesful
[18:55:10] <Avenger> what are those? can i help somehow?
[18:55:41] <lynxlynxlynx> i'm trying to fix pst stores, but i still haven't managed to make them close properly
[18:56:13] <Avenger> they shouldn't be different from other games, wrt closing
[18:56:45] <lynxlynxlynx> i'm fiddling with the windows and their positions, but the main part remains drawn, the game control doesn't refresh there
[18:57:13] <lynxlynxlynx> the most similar setup is in iwd2, which works a bit better
[18:57:31] <Avenger> i bet you somehow close the gamecontrol accidentally?
[18:57:43] <Avenger> that's the only case when it won't refresh
[18:58:07] <Avenger> it is always the 0 window, so it can get closed accidentally
[18:58:20] <lynxlynxlynx> i'll check
[18:58:38] <lynxlynxlynx> the closing code is very similar to the ones in the other games, but it is worth a shot
[18:58:39] <Avenger> maybe it helps if you set windows to None initially
[18:58:51] <Avenger> closing none will bug out ;)
[18:59:26] --> SiENcE has joined #GemRb
[18:59:38] <Avenger> hmm it is all none, though
[19:01:54] <Avenger> hmm another question:HideGUI/UnhideGUI seems to be not needed in most of the code
[19:02:21] <lynxlynxlynx> it helps with removing flicker
[19:03:03] <lynxlynxlynx> but yes, the pst guistore does it too often
[19:06:17] <Avenger> yes, that's what i meant
[19:06:42] <Avenger> i think using it too often may cause trouble
[19:07:38] <fuzzie> i was thinking of reorganising it anyway
[19:07:48] <lynxlynxlynx> doesn't help in this case
[19:07:55] <fuzzie> it has some bugs and it doesn't open at all with some ui mods
[19:08:13] <fuzzie> but i have no pst here to look at the pststore
[19:15:02] <Avenger> ok, i'm going back to reverse engineering mode
[19:15:06] <-- Avenger has left IRC (Quit: bye!)
[19:16:23] <lynxlynxlynx> well well well
[19:16:40] <lynxlynxlynx> window width of 65176
[19:17:17] <fuzzie> hehe
[19:18:08] <lynxlynxlynx> no, actually that's the owner width, the window is /just/ 1000
[19:22:53] <lynxlynxlynx> it appears a lot of the chus have windows with big sizes (black padding)
[19:28:29] <lynxlynxlynx> hmpf, maybe this is my fault
[19:28:46] <lynxlynxlynx> i have a custom resolution built
[19:29:34] <lynxlynxlynx> plenty of individual chus in the override
[19:31:10] <fuzzie> yeah, the widescreen mod falls under 'some ui mods' above :|
[19:31:35] <fuzzie> the original engine just ignores the sizes for a lot of windows, i think
[19:31:47] <lynxlynxlynx> i forgot it does things differently for pst and bg1
[19:34:20] <lynxlynxlynx> well, using that resolution doesn't change a thing :)
[19:38:57] <-- budlust has left IRC (Ping timeout: 240 seconds)
[19:41:21] --> budlust has joined #GemRb
[19:46:42] <lynxlynxlynx> maybe i should just start in reverse
[19:47:01] <lynxlynxlynx> copy the bg2 one over and fix the chu differences
[19:50:51] <lynxlynxlynx> uh, it's twice the size
[20:44:03] <lynxlynxlynx> yay, it closes that way
[20:55:01] <fuzzie> :)
[21:31:34] --> Maighstir_laptop has joined #GemRb
[21:37:40] <-- Maighstir_laptop has left #GemRb
[22:34:32] <-- lynxlynxlynx has left IRC (Remote host closed the connection)
[22:36:14] <-- SiENcE has left IRC (Quit: cya @all)
[23:03:16] --> Gekz has joined #GemRb
[23:07:36] <-- Edheldil_ has left IRC (Quit: Really?)