#gemrb@irc.freenode.net logs for 29 Sep 2011 (GMT)

Archive Today Yesterday Tomorrow
GemRB homepage


[00:22:27] <-- brad_a has left IRC (Ping timeout: 260 seconds)
[00:36:15] --> brad_a has joined #gemrb
[01:17:13] --> barra_away has joined #gemrb
[01:20:15] <-- barra_home has left IRC (Ping timeout: 248 seconds)
[03:39:38] <-- barra_away has left IRC (Quit: Verlassend)
[04:56:21] <-- brad_a has left IRC (Quit: brad_a)
[06:38:20] --> lynxlynxlynx has joined #gemrb
[06:38:21] <-- lynxlynxlynx has left IRC (Changing host)
[06:38:21] --> lynxlynxlynx has joined #gemrb
[06:38:21] --- ChanServ gives channel operator status to lynxlynxlynx
[07:50:01] --> lubos has joined #gemrb
[10:26:42] <lynxlynxlynx> the weather is too good, release postponed :)
[10:29:10] <edheldil> :)
[10:29:16] --> Maighstir has joined #gemrb
[10:29:24] <edheldil> are you leaving for a holiday?
[10:31:23] <lynxlynxlynx> no, but i was on vacation yesterday
[10:31:46] <lynxlynxlynx> we went hiking the night before, then hiked the whole yesterday
[10:32:14] <lynxlynxlynx> usually it's only on weekends, but now it's a stable anticyclone streak :D
[10:32:58] <lynxlynxlynx> https://picasaweb.google.com/117343016675304973542/Miselj# <--
[10:57:11] <wjp> wow, nice scenery
[11:07:45] <lynxlynxlynx> definitely
[11:08:18] <lynxlynxlynx> not many pics of the view, but you get the idea
[11:30:23] <edheldil> beautiful
[11:32:01] <edheldil> for a contrast, I have spent some time yesterday here ... http://arniwup.com/test/?galerie=Malostransky%20Hrbitov :)
[11:36:20] <DrMcCoy> That's also some nice scenery
[11:40:03] <lynxlynxlynx> in opera, i just get a black page
[11:40:54] <lynxlynxlynx> arora shows the blog, but no pics
[11:41:08] <DrMcCoy> Well, I get a page with (Czech, I guess) text there, but the "Galerie" link goes to the pictures
[11:41:15] <lynxlynxlynx> yeah
[11:49:19] <edheldil> I will tell it to the photographer, there were others with problems. Would you care to tell me the browser versions?
[11:51:32] <fuzzie> It seems to be expecting a session cookie?
[11:52:13] <edheldil> it displays ok for me, but I am still on FF3
[11:52:55] <DrMcCoy> edheldil: iceweasel-7.0~b4-1 . There's also an issue with the image thing with JavaScript enabled (which I normally don't have), when clicking an image, that animate-slide thing only displays about 1/5 of the image's width
[11:54:13] <DrMcCoy> With JavaScript disabled, it just opens the image directly, which is I actually prefer anyway
[11:54:35] <edheldil> ok, I will report it :), thank you :)
[12:24:34] --- Maighstir is now known as Maighstir|away
[12:36:46] <lynxlynxlynx> 10.52
[12:37:05] <lynxlynxlynx> err, 11.51
[12:40:16] <edheldil> opera?
[13:08:44] <-- lubos has left IRC (*.net *.split)
[13:09:37] <lynxlynxlynx> yes
[13:10:41] --> lubos has joined #gemrb
[13:15:17] <-- lynxlynxlynx has left IRC (Ping timeout: 276 seconds)
[13:22:03] --> lynxlynxlynx has joined #gemrb
[13:22:03] <-- lynxlynxlynx has left IRC (Changing host)
[13:22:03] --> lynxlynxlynx has joined #gemrb
[13:22:03] --- ChanServ gives channel operator status to lynxlynxlynx
[14:26:43] --> Yoshimo has joined #gemrb
[14:35:32] --> yyz_ has joined #gemrb
[15:06:53] --> brad_a has joined #gemrb
[15:23:47] <-- lubos has left IRC (Quit: Leaving.)
[15:31:01] <-- brad_a has left IRC (Read error: Connection reset by peer)
[15:31:30] --> brad_a has joined #gemrb
[16:10:01] --> barra_home has joined #gemrb
[16:29:52] --> pupnik has joined #gemrb
[16:37:30] <-- yyz_ has left IRC (Read error: Connection reset by peer)
[16:44:01] --> yyz_ has joined #gemrb
[17:02:13] <-- yyz_ has left IRC (Quit: leaving)
[17:13:17] <pupnik> http://www.youtube.com/watch?v=yHJOz_y9rZE [ Floppy music DUO - Imperial march ]
[17:38:24] <-- Gekz has left IRC (Ping timeout: 248 seconds)
[18:16:47] --> kettuz has joined #gemrb
[18:47:20] --- Maighstir|away is now known as Maighstir
[19:13:35] --> Beh0lder has joined #gemrb
[19:13:43] <Beh0lder> hi all
[19:18:07] <lynxlynxlynx> oj
[19:19:05] <pupnik> moo
[19:19:58] <Beh0lder> official SDL for Android is a fake(. it's not working on devices, only in emulator
[19:20:13] <brad_a> thats a shame
[19:21:11] <lynxlynxlynx> well, 1.3 doesn't exist yet, so it is better to call it "in progress"
[19:21:20] <pupnik> boo
[19:23:51] <Beh0lder> it crashes on initializing opengl subsystem
[19:24:44] <brad_a> search the bug reporter where i found those multitouch patches
[19:24:55] <brad_a> often there are fixes for those things floating around
[19:25:12] <brad_a> i have had to do that for at least 2 issues with sdl on ios
[19:28:01] <Beh0lder> I seen these patches, but I can't apply it to pelya's port. It's so different to official.
[19:28:28] <pupnik> Beh0lder: where's a good place to download a working android sdk with sdl
[19:31:20] <Beh0lder> sdk and ndk on developer.android.com
[19:33:03] <Beh0lder> SDL with libs there: https://github.com/pelya/commandergenius
[19:33:56] <brad_a> oficial sdl is in the same repo as sdl for everything else
[19:34:24] <-- Beh0lder has left #gemrb
[19:36:05] <fuzzie> but indeed I haven't heard any tales of it working.
[19:36:22] <fuzzie> i mean, the official one.
[19:37:01] <fuzzie> pelya's one is a hackish mess but it's v.useful, works on pretty much all devices and provides a large heap of options.
[19:37:07] <brad_a> i have seen a couple of threads with people using officail sdl on android with multitouch...
[19:37:18] <fuzzie> any idea which?
[19:37:33] <brad_a> i know one was on the sdl forums
[19:37:42] <brad_a> but he was on honeycomb
[19:39:59] <brad_a> i guess i dont actually know that it was working on a device vs emulator tho
[19:43:02] <fuzzie> well, it's a large jump from one device to all devices anyway
[19:54:49] <pupnik> i wish android had specified a few hardware buttons
[19:54:53] <pupnik> but they are out of style
[19:55:08] <pupnik> note to manufacturers - my hands are not transparent
[19:55:20] <fuzzie> well, it did, of course, and then they decided to remove that requirement
[19:55:27] <pupnik> oh
[19:55:30] <pupnik> ty
[19:55:40] <pupnik> bad Jobs
[21:06:29] <brad_a> something really basic and simple is escaping me when creating these ttf fonts. i have created the sprBuffer surface and populated the size array yet i get nothing :(
[21:06:52] <brad_a> i know my sprite is valid because i have overridden printfromline to just blit that and it works perfectly
[21:07:16] <brad_a> and inspecting the size array in gdb show the expected results
[21:07:34] <brad_a> is it maybe that im working with 32 bit sprites?
[21:08:25] <tomprince> There is a lot of assumption build into the code about which blitting function get passed sprites of various different types.
[21:08:42] --> Beh0lder has joined #gemrb
[21:09:00] <brad_a> oh i see
[21:09:11] <brad_a> maybe then it is because im using 32 bit sprites
[21:09:16] <fuzzie> well, specifically, the font renderer uses palettes
[21:09:22] <fuzzie> since it needs to be able to colour text
[21:10:21] <fuzzie> so if you're using the existing Font::PrintFromLine in your new font class then that sounds one likely culprit
[21:11:16] <brad_a> no im not really wanting to override that i am jsut using that function to verify my sprite is what i expect
[21:11:32] <brad_a> oh nevermind
[21:11:35] <brad_a> i cant read
[21:28:34] <brad_a> well maybe it is blitting. when i use the original printfromline it appears that everything is shifted down a bunch so it is likely out of bounds on the buttons...
[21:29:44] <brad_a> success!
[21:29:52] <brad_a> except its pure gibberish lol
[21:30:18] <brad_a> also colors dont work as fuzzie mentioned :-p
[21:31:13] <brad_a> for some reason i have to boost the yPos on all the characters… is that expected?
[21:33:24] <lynxlynxlynx> depends on where they're anchored - ttf probably at the bottom, bams at top left?
[21:34:32] * pupnik cheerleads brad_a's work
[21:34:39] <brad_a> :)
[21:34:53] <pupnik> oh i hate that mucking about with offsets
[21:35:07] <pupnik> when you don't know why things are where they are
[21:35:32] <brad_a> well at this point im jsut gald SOMETHING is rendering
[21:35:35] <fuzzie> the yPos is the position above the baseline to draw at, right?
[21:35:49] <brad_a> im guessing so
[21:40:15] <brad_a> i must have the indexing on the size array messed up leading to gibberish instead of sensical words
[21:41:37] <brad_a> I'll have to pick this back up later
[21:41:43] <brad_a> thanks for the input all
[21:41:48] <-- brad_a has left IRC (Quit: brad_a)
[21:54:38] <-- Yoshimo has left IRC (Quit: Yoshimo)
[22:08:48] <-- lynxlynxlynx has left IRC (Remote host closed the connection)
[22:34:20] <-- Beh0lder has left #gemrb
[22:40:14] --> jschall_ has joined #gemrb
[22:40:25] <-- jschall has left IRC (Read error: Connection reset by peer)
[22:41:16] <-- jschall_ has left IRC (Remote host closed the connection)
[23:19:41] --> brad_a has joined #gemrb
[23:21:17] <brad_a> pfff it was an off by 1 "error". in my opinion you should access a character with size['A'] for A instead of size['A'] - 1 shall i assume there is a reason that i dont see ATM?
[23:21:21] <brad_a> also http://dl.dropbox.com/u/13866402/teaser.png
[23:42:57] <pupnik> 3:)
[23:43:26] <pupnik> becase the first character is '0'?
[23:43:35] <pupnik> index 0
[23:47:48] <brad_a> well i had index 0 as '\0' but thats how ascii is anyway
[23:48:44] <pupnik> ok
[23:48:47] <brad_a> and that doesnt change the way i feel about accessing using the character as teh index
[23:50:06] <pupnik> i don't understand it from the english
[23:51:18] <brad_a> well it doesnt matter :) i fixed it. i just dont understand why it needed fixing