#uwadv@irc.freenode.net logs for 27 May 2003 (GMT)

Archive Today Yesterday Tomorrow
Underworld Adventures homepage


[13:36:17] --> wjp has joined #uwadv
[13:36:17] --- ChanServ gives channel operator status to wjp
[19:19:29] --> Dark-Star has joined #uwadv
[20:49:54] --> Eldron has joined #uwadv
[23:01:40] <-- Dark-Star has left IRC ()
[23:12:43] --> pestix has joined #uwadv
[23:13:22] <pestix> Hi everyone! Perhaps someone can help me - I have troble compiling uwadv from CVS...
[23:13:34] <pestix> uups, meant trouble
[23:22:08] <pestix> Well, anyway, for the logs: the Makefile generated by autoconf in the source/lua subdirectory seems to be broken.
[23:23:47] <wjp> what's the problem with it?
[23:23:54] <wjp> and what system are you using?
[23:24:34] <pestix> OK, so there's still some one awake ;-) . Well, I'm using the free Madrake 9.0 distro.
[23:25:22] <pestix> It tries to execute the strings "liblua.la" and "L/usr/bin" as commands...
[23:25:56] <wjp> barely awake :-)
[23:26:30] <pestix> me too, I am nearly of to bed...
[23:27:25] <wjp> at what point is it trying to run those commands?
[23:30:13] <pestix> "making all in hacking","all in tools", "zzlib", "resource"and - "lua", then it crashes. Executing the Makefile in source/lua itself exectes these commands at the very beginning, without compiling anything...
[23:30:44] <wjp> weird
[23:31:21] <wjp> can you send me your Makefile?
[23:32:16] <pestix> Yupp. Ahhh, can one simply send it over IRC? (Well, I don't use IRC often ;-) )
[23:33:01] <pestix> OK, found out...
[23:38:03] <wjp> hm, yes, that makefile is missing some rather essential parts
[23:38:23] <wjp> which automake do you have?
[23:40:21] <pestix> version 1.4-p6
[23:41:46] <wjp> hm, that's rather old
[23:42:20] <pestix> OK, then I'll try a newer version...
[23:42:39] <pestix> but not tonight, perhaps tomorrow... ;-)
[23:44:45] <wjp> :-)
[23:48:02] <pestix> Just queried the mandrake servers, they don't offer a updated version of automake, so I'll have to go through the trouble of compiling it myself :-( Well, tomorrow is another day, I'll try it then...
[23:48:28] <wjp> really?
[23:48:37] <wjp> mandrake 9 doesn't have automake 1.6 or anything?
[23:48:51] <wjp> try a package name like automake16 or something
[23:50:03] <wjp> very weird
[23:50:11] <wjp> automake 1.4 is rather antique
[23:50:31] <pestix> Ahhh. Even weirder. Just found automake 1.6 on the installation CDs.
[23:50:55] <pestix> So why don't these fools install it from the beginning anyway... well, let's try it...
[23:51:17] <wjp> 1.6 isn't fully backward compatible with 1.4
[23:52:49] <pestix> Ooops. Well, I just wondered if I could force RPM to rip it away. Well, what issues are to expect with backward compatibility...?
[23:53:07] <wjp> good question
[23:53:28] <wjp> haven't really noticed any myself, but apparently they do exist :-)
[23:53:57] <wjp> which 1.6 does Mandrake 9 have, btw? 1.6.3?
[23:55:34] <wjp> (versions before that have some other annoying bugs)
[23:55:49] <wjp> automake versions are a bit of a mess, if you hadn't guessed yet :-)
[23:55:59] <pestix> I just launched RpmDrake, it promised to update those packages, let's see... a moment...
[23:56:37] <wjp> anyway, I should really be going
[23:56:48] <wjp> goodnight and goodluck
[23:57:02] <-- wjp has left IRC ("Zzzz...")
[23:57:06] <pestix> Ahhh, 1.6.3. Well, I already feared something messy ;-). Well, g'night to you....