#uwadv@irc.freenode.net logs for 4 Aug 2003 (GMT)

Archive Today Yesterday Tomorrow
Underworld Adventures homepage


[16:13:16] --> wjp has joined #uwadv
[16:13:17] --- ChanServ gives channel operator status to wjp
[16:22:20] --> elias has joined #uwadv
[16:22:20] <elias> Hello
[16:22:20] <wjp> hi
[16:22:20] <elias> I'm trying to run uwadv (the latest version)
[16:22:20] <elias> but it doesn't work with DRI enabled
[16:22:34] <wjp> it uses openGL
[16:22:41] <wjp> not sure how your opengl drivers interact with dri
[16:22:55] <elias> well glxgears works greatly
[16:23:04] <elias> and many opengl games work
[16:23:13] <wjp> hm, ok
[16:23:25] <wjp> so it does run without dri?
[16:23:39] <elias> yes but veeeeeeeery slowly
[16:24:05] <wjp> uwadv uses opengl through SDL, so we have relatively little control over it
[16:24:17] <elias> I see
[16:24:19] <wjp> you could try upgrading SDL
[16:24:25] <elias> ok
[16:24:31] <wjp> which 3d card do you have, btw?
[16:24:43] <elias> it's a SiS 730
[16:24:48] <wjp> hm
[16:24:53] <elias> it's not that good, but it usually works
[16:24:55] <wjp> didn't that have dri issues?
[16:25:06] <wjp> or maybe that was a few kernels ago
[16:25:25] <elias> I tried with both 2.4.21 and 2.6.0-test2
[16:25:44] <elias> loading all critter animations ... done, needed 1412 ms
[16:25:44] <elias> SIS driver : out of video/agp memory
[16:25:44] <elias> Fatal errors in sis_dri.so
[16:25:49] <elias> This is the error I got
[16:26:03] <wjp> oh, maybe it just doesn't have enough texture memory
[16:26:29] <wjp> does the card have its own video memory or does it use system memory?
[16:26:52] <elias> it uses system memory
[16:27:08] <elias> I've set it up to use up to 64 MB of system memory
[16:27:14] <wjp> should be plenty
[16:27:20] <wjp> I only have 32Mb on my video card, anyway
[16:27:25] <elias> but still I've got the same error..
[16:27:45] <elias> OpenGL stats:
[16:27:46] <elias> bit depths: red/green/blue/alpha = 8/8/8/0, depth=32
[16:27:46] <elias> max. texture size = 2048 x 2048, max. lights = 8
[16:27:46] <elias> stack depths: name stack = 64, modelview stack = 32, proj. stack = 32
[16:27:46] <elias> vendor: Brian Paul
[16:27:46] <elias> renderer: SiS 300/630/530 DR Mode
[16:27:48] <elias> version: 1.2 Mesa 3.4.2
[16:29:16] <wjp> brb
[16:29:19] <elias> ok
[16:33:51] <elias> w
[16:34:33] <wjp> b
[16:34:39] <wjp> hm
[16:34:43] <wjp> not sure what the problem would be
[16:35:08] <elias> :-(
[16:35:37] <wjp> did you try windowed and fullscreen?
[16:35:44] <elias> yes
[16:35:46] <elias> I tried both
[16:36:20] <elias> I used to love that game, back in the old days, so I was very happy to play it again under Linux
[16:36:42] <wjp> it runs fairly well in dosbox
[16:37:21] <elias> you mean under w xp?
[16:37:41] <wjp> dosbox.sf.net
[16:38:24] <elias> I didn't know dosbox
[16:38:26] <elias> thank you!!!
[16:39:06] <wjp> np :-)
[16:39:14] <wjp> really cool project :-)
[16:39:20] <elias> it seems so
[17:05:05] <elias> thank you again
[17:05:06] <elias> bye
[17:05:07] <-- elias has left IRC ("BitchX: it does a body good")
[23:11:19] <-- wjp has left IRC ("Zzzz...")