#xu4@irc.freenode.net logs for 29 Mar 2011 (GMT)

Archive Today Yesterday Tomorrow
xu4 homepage


[00:44:46] <Darrenor64> yeah agreed. I don't like them much either. Besides the weirdness of bunching up around tile edges, do you find they're generally bad?
[03:06:43] <-- wjp has left IRC (*.net *.split)
[03:06:43] <-- Darrenor64 has left IRC (*.net *.split)
[03:06:45] <-- Kirben has left IRC (*.net *.split)
[03:06:58] <-- ChanServ has left IRC (*.net *.split)
[03:18:20] --> ChanServ has joined #xu4
[03:18:20] --> Kirben has joined #xu4
[03:19:07] --> Darrenor64 has joined #xu4
[03:20:05] --> wjp has joined #xu4
[12:22:14] <-- Kirben has left IRC ()
[12:53:19] --> Yuv422 has joined #xu4
[12:53:42] <Yuv422> "XU4 Error"
[12:53:47] <Yuv422> "Was no file"
[12:55:20] <Yuv422> I'm running on an intel mac 10.6.6
[12:56:11] <Yuv422> snapshot dated 2011-03-28 5:58
[12:56:39] <-- Yuv422 has left IRC (Quit: Yuv422)
[13:41:52] --> Dominus has joined #xu4
[16:48:52] <Darrenor64> Committed code to give more detail for Yuv's problem.
[16:49:06] <Darrenor64> Tell him, "Thanks"
[18:01:44] <-- Darrenor64 has left IRC (Ping timeout: 246 seconds)
[18:07:19] --> Darrenor64 has joined #xu4
[20:24:43] --> Yuv422 has joined #xu4
[20:28:59] <Yuv422> The latest snapshot is crashing now
[20:29:02] <Yuv422> 0x000000010005eec9 U5LzwImageLoader::U5LzwImageLoader() + 21447
[20:31:01] <Yuv422> http://pastebin.com/Ny3U3Kaq
[20:35:54] <Darrenor64> Hello.
[20:36:01] <Darrenor64> It seems you're trying to use images from ultima 5?
[20:36:05] <Darrenor64> or 6
[20:36:34] <Yuv422> hey
[20:36:41] <Yuv422> that's strange
[20:37:53] <Yuv422> cd ~/Library/Application\ Support/XU4/
[20:38:03] <Yuv422> $ ls
[20:38:03] <Yuv422> Ultima4.zip
[20:39:11] <Darrenor64> Hmmm. Hold on.
[20:39:37] <Yuv422> http://pastebin.com/g8hrN7mg
[20:39:42] <Darrenor64> see what happens if you rename that file to ultima4-1.01.zip
[20:39:45] <Yuv422> this is the contents of the zip
[20:40:18] <Darrenor64> or, unzip it to ./ultima4
[20:40:49] <Yuv422> renaming the zip causes the same crash
[20:40:57] <Yuv422> I'll try exploding it
[20:41:49] <Yuv422> bingo
[20:41:52] <Yuv422> that worked
[20:45:28] <Darrenor64> very good. I'm wondering if we should encourage people to unzip in the documentation.
[20:45:40] <Darrenor64> Have you used xu4 much in the past?
[20:45:48] <Yuv422> first time
[20:45:50] <Yuv422> :-)
[20:46:01] <Yuv422> and I would have usually unzipped
[20:46:15] <Yuv422> but I saw you could use a zip file so I did that
[20:46:24] <Darrenor64> I hope you enjoy it. Come back and let us know how it goes.
[20:46:35] <Darrenor64> I'll ask our packagers and see what they think of the idea.
[20:46:40] <Darrenor64> Of dropping the zip stuff.
[20:47:06] <Darrenor64> Have a nice quest!Q
[20:47:25] <Yuv422> :)
[20:58:30] <Dominus> heyho
[20:58:45] <Yuv422> hey Dominus
[20:58:54] <Dominus> i wonder why the zip is not working
[20:59:24] <Yuv422> does it unzip to a temp location?
[20:59:45] <Yuv422> I think my mac filesystem is case sensitive
[21:00:07] <Dominus> oh, that may be the problem, since it works nicely here
[21:03:47] <Dominus> darrenor, di you decide yet on what to do with older releases which included the u4 zip?
[21:07:23] <Darrenor64> Hello.
[21:07:38] <Darrenor64> I've been having trouble with zip file names as well.
[21:07:45] <Darrenor64> Could be a case thing, yeah.
[21:07:59] <Darrenor64> Hmm, I haven't thought about the old releases.
[21:08:05] <wjp> I see the u4 takedowns are actually on slashdot
[21:08:20] <Yuv422> yeah
[21:08:22] <Darrenor64> Now that we have, it would be wise to delete them.
[21:08:30] <Yuv422> that's a lot of exposure
[21:08:37] <Dominus> :) sorry for bringing it up :)
[21:08:41] <Darrenor64> Hahahaha.
[21:08:57] <Darrenor64> not a problem. would you like to perform the ritual purging?
[21:09:09] <Dominus> I deleted the ages old os x snapshot right now
[21:09:45] <Darrenor64> could you guys check the following out: https://sourceforge.net/apps/phpbb/xu4/viewtopic.php?f=1&t=22
[21:09:54] <Darrenor64> i can't reproduce the bug on my windows build.
[21:11:34] <Dominus> can't reproduce it here either
[21:12:21] <Darrenor64> perhaps some wonky linux libs.
[21:12:25] <Darrenor64> old SDL
[21:13:01] <Dominus> updated the homepage
[21:13:34] <Dominus> ok, let's see about the old releaes and which ones do have the u4 zip included
[21:13:59] <Darrenor64> good luck, and thanks :)
[21:14:15] <Dominus> bah, that's many files to check
[21:14:17] <Darrenor64> luckily i have a linux system beside me with most of the src from svn ready to build.
[21:14:27] <Darrenor64> could just kill them all. ?
[21:14:38] <Darrenor64> who wants to use buggy old xu4 anyway, right?
[21:14:49] <Darrenor64> (unless it's more buggy now??)
[21:15:21] <wjp> it doesn't even compile for me on linux
[21:15:24] <Dominus> i wonder if we can hide them
[21:15:28] <wjp> sound_sdl.cpp:8:23: error: sound_SDL.h: No such file or directory
[21:15:38] <wjp> (case problem, it seems)
[21:17:08] <Darrenor64> that filenmae error was fixed in an explicit svn commit.
[21:17:31] <Yuv422> hmm I'm having the usual 32/64bit lib build issues
[21:17:41] <wjp> I just checked out svn trunk, though
[21:17:46] <Darrenor64> VERY odd.
[21:17:59] <Darrenor64> Ah
[21:18:41] <Darrenor64> wait, i didn't actually rebuilt.
[21:19:11] <Dominus> Yuv422: svn should build fine on in 64bit if you follow the guide on /doc/xu4MacOSXsvn.txt
[21:19:21] <Yuv422> yeah my bad
[21:19:33] <Yuv422> I had an outdated SDL framework in my /Library dir
[21:19:38] <Dominus> oh :)
[21:19:41] <Darrenor64> It looks like I have to fix the linux build.
[21:19:45] <Darrenor64> I messed it up.
[21:19:50] <Darrenor64> SDL-related includes, I bet.
[21:20:16] <Darrenor64> judging from some commentary, it has a few workarounds here and there.
[21:22:00] <Darrenor64> i really wish debian would update their SDL_mixer and mikmod libs
[21:22:26] * Dominus is sad about deleting old builds... beta3 needed os x and rpm to be deleted...
[21:27:26] <wjp> no crash here, and valgrind does show a few warnings, but probably not related
[21:28:33] <Darrenor64> wjp, what did you change to get it to build?
[21:29:17] <wjp> sound_SDL.h -> sound_sdl.h
[21:29:22] <Darrenor64> oh right.
[21:31:42] <Yuv422> could the zip bug I was experiencing be due to the ultima4.zip no longer being included in the bundle
[21:31:57] <Yuv422> maybe it loads the vga patches
[21:32:10] <Yuv422> then crashes trying to load the internal u4 zip
[21:33:56] <Yuv422> it trying to get "title"
[21:34:52] <Yuv422> title.ega
[21:36:29] <Darrenor64> what are some of the valgrind warnings?
[21:42:15] <Dominus> Yuv422: that shouldn't be the cause. I never bundled the zip with the snapshot since I started doing the snapshots
[21:44:39] <Dominus> can you try playing with cases? for example ultima4.zip not Ultima4.zip?
[21:56:34] <Yuv422> I'll give that a go tonight
[21:56:51] <Yuv422> and I'll try stepping through the loader to see where things go wrong
[21:56:58] <Yuv422> cya
[21:57:00] <-- Yuv422 has left IRC (Quit: Yuv422)
[22:01:44] <Darrenor64> Hmm... I rebuilt xu4 on my linux box, made a few minor changes, and now it says "Illegal Instruction"
[22:02:02] <Darrenor64> after briefly opening the windows.
[22:04:22] <wjp> I got that when it couldn't find the data
[22:04:52] <Darrenor64> hmmm... maybe i can make it a little smarter.
[22:05:11] <wjp> an error message instead of a crash in this case would probably be good :-)
[22:05:18] <wjp> but I didn't look further why/where it's crashing
[22:09:11] <Dominus> yeah, xu4 bundle crashed for me too when it couldn't find the zip right now
[22:20:47] <Dominus> releases cleaned - all os x and linux binary packages down to ad including 0.8 needed to be killed. windows versions were always good
[22:28:47] --> Kirben has joined #xu4
[22:28:48] --- ChanServ gives channel operator status to Kirben
[22:34:55] <-- Dominus has left IRC (Quit: Leaving.)